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1. Introduction to the ClassPad 
 

The ClassPad is a natural, sophisticated form of a graphical calculator. Go with an 
impressive collection of applications and self-learning applications like 3D-Graph, 
Geometry, eActivity, SpreadSheet and much more. 

 
The device allows adding text, both in English and in Bulgarian, and it appears in 

the way it is presented in the textbook. The authorization of texts, graphics, drawing, 
computing and other operations can be made quickly and authentically a large LCD 
screen. The ClassPad calculator offers several graphical tools necessary for plotting 
3D-graphics and geometric objects that create a very favorable environment for 
education and training of students by themselves. 

 
Interface of the calculator using pull-down menu format that simplifies even 

complex operations at first glance. Multiple sentences, phrases and other topics can be 
selected with the touch of a stylus. The ClassPad supports 'drag and drop', ‘copy and 
paste' operations, and others who minimize the use of any other key operations. 

 
Applications for presentations and tools for creating materials for lectures and to 

solve a wide range of tasks, allowing teachers to present these in a manner 
understandable to students and provides a good basis for understanding of 
mathematical concepts and problems in the process of solving them. The individual 
transaction can be captured and later added to the presentation and put in slideshow 
format. 

 
Administration eActivity allows working with expressions, formulas, figures and 

other graphics, allowing students to learn and advance themselves using their personal 
methods for solving problems, utilizing well known algorithms for solving them. This 
is a cross (only) teaching tool that helps to study the various processes and sharing of 
mathematical solutions. ClassPad allows a comprehensive understanding of the 
problem by helping students to discover and develop their own capabilities. 

 
The calculator can conveniently connect to computer to transfer information as is 

possible and implement the transfer of photos. The ClassPad Manager software is 
given in CD-ROM, which comes with a calculator and an additional cable. It can be 
performed to transfer programs and materials (e-Activities) of your ClassPad to a 
computer or by using the ClassPad Manager software to a ClassPad. 

 
ClassPad is not just a graphical calculator, a next-generation calculator, for 

scientific research and educational purposes. With ClassPad students can manipulate 
complex mathematical expressions by translating them to simple and straightforward 
equations, allowing easy understanding of the connections between different 
mathematical fields (vector and geometry). Offers a new perspective on mathematics, 
bringing it to the other, easy to understand examples. 

 
The ClassPad is different from other well known calculators because it offers: 
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-   Input of informations with a touch of the stylus;  
-   Provides input / output natural mathematical expressions (e.g. Program Mode); 
-   Calculation with ClassPad is easily and quickly using fractions, limes,    
     differentials, integrals, matrices, and many other built-in functions;  
-   Displaying the result in its natural mathematical form;  
-   Four new applications included as a supplement to the calculator:  
     eActivity, Geometry, Presentations and 3D-graphic. 

 
 
1.1  eActivity application 
 

The eActivity and Presentation application are easy to manipulate, exploitation 
/ exploration and sharing of solutions can be found without a large audience. This 
helps students to increase awareness and improve their personal opportunities in the 
field to mathematics. 

  
The eActivity has four main advantages to using a sheet and a pen: 
 
-   Use this application to create a favorable environment for personal  

  development as well as materials for lectures and presentations;  
 
-   Provides students work on tasks in their own pace and capability;  
 
-   Allows the detection of different ways to solve problems;  
 
-   Allows text expressions, shapes and graphics to be displayed on the screen  

 of  the ClassPad 330. 
 
What is eActivity? 
 

This is a new electronic tool that can be freely studied in ClassPad. With this 
application can benefit all the useful features built into the ClassPad 330. It is both a 
textbook and workbook. Teachers can use it to create electronic examples and 
exercises to solve problems using text, mathematical expressions, 2D- and 3D-
graphics, geometric drawings and tables. The eActivity provides students with an 
environment for research and development, allowing them to save the results 
obtained, combined with observations on their part.   
 

The eActivity application provides text input and mathematical expressions 
and Applied ClassPad informations, save the file as 'eActivity'. A standard eActivity 
file contains text informations placed in band or line. The order may be in the form of 
'Row text', 'Geometric row' or 'Calculation row'. As a band / band takes the form of 
so-called. 'Application data strip' (main, geometry, graph, conics sequence, etc.) 
  
 
Create an eActivity  
 
   Press the 'Menu' to visualize the 'Application menu', from which we select the 
icon for eActivity. It displays the window of the eActivity, as it was shown last time 
when it was used. When choosing a file / new will open a new window, and old 
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information will be deleted. There are four types of informations that can be 
incorporated into eActivity window: text, calculation expression, geometric object or 
process information for display. After eActivity is the way we want to be saved from 
the file / save. It is shown a file-dialog box, then select folder and file name 
(maximum 20 characters) is pressed to save. Saved files are sorted in an area of 
memory which is divided from the memory for other types of information. Therefore 
e.g., Managing eActivity file can not be accessed to the Variable Managing or 
Managing in a Geometry Application file. 
 

The text row is used to add text and mathematical expressions in the normal 
state, as the text can thicken. The calculation row is used to bring computing 
operations which are valid in the Main application. The application data strip display 
window of any application ClassPad (e.g. Main, Graph and Table, Geometry) and use 
the window to create information that can be later incorporated into eActivity, 
Geometry link row is made to communicate with geometric shapes. They all add the 
menu ‘Insert’. 

  
  
 

             
 
 
 The text row inserted text and mathematical expressions, but which is not 
feasible in choosing the Execute button. All commands in the Text row are treated as 
text. When the text that is entered is too long, the cursor is automatically transferred to 
the next line. When entering mathematical expressions, the cursor stays on the same 
line, even if the expression is too long. Arrows appear to indicate that there is 
information to the left or right of it. 
  
 
 The calculation row allows the execution of any calculations of eActivity 
application. When we introduce the mathematical expression, the result is displayed 
aligned to the right of the screen. You can always edit the information entered, but 
never the result. In case of wrong entered expression result will appear. 
  



 -6-

 
 
 
 
If the required result will not be displayed it should not be pressed Exe button 

from the built-in keyboard ClassPad. When you change the input, output is 
automatically changed. Even mathematical expressions, which are generally 
introduced into eActivity without calculation, are calculated and their results are 
displayed. 

 
  
The application data strip can be used if required to add information from any 

other application into the eActivity. This element contains a field in which it may be 
heading information and a button that when pressed it takes us to the desired 
application. Often the screen is divided to two halves. Active is the half that is 
selected. Adding Application data is from the Insert menu and choose Strip. Right of 
the screen appears with a drop-down menu choices, which give access to applications 
such as ClassPad Graph: 2D, 3D, graphics of differential equations, tables and 
geometric objects, and many others. 
  
 
 
 E.g. to add Geometry data choose Insert → Strip → Geometry. A window 
similar to the previous-field in which it may be heading the project or development 
and button pressing of which screen is divided into two and visualize geometric object 
that is selected from the toolbar 
  
 

 
 
 
 In the same way you can add graphics. The main point here is that we need to 
prove equations needed for plotting graphs. The drawing may have more than one 
graph plotting each be made with different thickness of the line. 
  
 
 

This button shows that we are in the 
 Calculation input mode 

The checkmark appears at the beginning of the 
line when the calculation mode is selected 
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Adding this feature it is the button 9, you can add up to 100 functions.  
 
  You can use the Notes field to add any information. Notes is a text box for 
editing and styling comments or add explanations in complex mathematical 
expressions in eActivity.  
 
  When selecting Insert → Strip → Notes a window opens in the lower half of 
the screen. From the toolbar, inserted text may be adjusted in a way that we want. 
This application is only active in eActivity.  
 
  eActivity allows previewing the image (bitmap image). Adding this feature it 
is the button S choose it by Insert → Strip → Picture, in which the lower half of 
the screen window is opened for adding an image. When choosing File → Open menu 
opens the file chooser, but the main thing is, it must be of type PICT.  
 
  eActivity is both notebook and textbook, allowing to explore the world of 
mathematics. Almost any expression of eActivity may be included in any of the other 
applications as well be taken information from external applications and be included 
in eActivity. 
 
 

The addition of Geometry link row is automatically added the information in 
the Geometry window by liaising with information eActivity. It can be visualized as 
lines and shapes values or mathematical expressions in Geometry link row. Dragging 
a line or geometrical figure of Geometry window to Geometry link row turns them 
automatically into their equivalent mathematical expression. This expression is related 
to the Geometry window, making change and who have been provided valid and 
visualization figure at the bottom of the screen. The change of expression in 
Geometry link automatically changes shape in Geometry window. 
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 It is possible to transfer eActivity files to another ClassPad Unit, but it needs 
the host file part to support all types of Application data strip (Graph, Graph Editor, 
3D Graph, 3D Graph Editor, Conics Graph, Conics Editor, Geometry, SpreadSheet, 
Stat Graph , Stat Editor, DiffEqGraph, DiffEqGraph Editor, Financial, Probability, 
NumSolve, Sequence Editor, Picture Viewer, Note, Main, Verify). If we transfer 
information to another ClassPad, which does not support some of these applications, 
the recipient can not open the file. 

  
 
It is possible also a transfer between ClassPad and a computer. Here it could 

be used FA-CP1. It is desirable first to check the version of the FA-CP1, a computer 
loaded with the operating system of the ClassPad, to determine whether they are 
compatible. Another way to accomplish the transfer, which is much more convenient 
is using Exchange window on the ClassPad Manager (appears when you press the 
right mouse button). When that opens a dialog ClassPad Manager-Exchange. When 
ClassPad is connected to the computer the screen from left to become visible from 
computer files and ClassPad. Transfer is carried out in drag and drop the selected file. 

  
 
 The eActivity is also useful in the classroom and at home. Students can easily 

change their own mathematical expressions or numerical values and solve problems 
they themselves award. Based on the results obtained, it is possible to prepare 
presentations. For convenience, use Presentation application and RM-ClassPad. 
Features provide a margin presentation of information that appears on the LCD screen 
as a picture or in the form of slides. This is a very effective way of presenting the 
results of a study group or a major project. The presentation may be more effective if 
complemented by RM-ClassPad projection by OHP. It allows you to send to the date 
of the calculator screen or wall. 
  
 
 
 
 
 
 

• In the drag / drop 
function it is 
plotted quickly 
geometric 
shapes; 

• When you 
change the para-
meters easily and 
effectively 
change the 
dimensions of 
the selected 
shape. 
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 In the ClassPad it is interesting and it must be addressed the organization of 
files. The system is divided into two directories, one that is outside eActivity, Main 
and others, and another which is included in eActivity, Main, etc. The two unrelated 
directories and files from one can not be read or processed by / in the other. However 
calls can be made and this became possible with the help directory library, which 
serves as a link between the other two. 
  
 
1.2  Presentation application 
 

Presentation application allows a picture to other Windows applications, 
organizing in the form of its presentation. With the application can realize and correct 
the contents when necessary. Presentation, for example, can show how they obtained 
the interim and final results step by step. They can be used in the classroom and / or 
other performance by connecting with ClassPad OHP-projector. Thus, teachers can 
submit their work before a large audience, doing tasks understandable and accessible 
to others. Students, on the other was using the application can gracefully make their 
tasks, essays and projects. 

  
The application is started from Presentation application icon in the main menu. 

Opens the following dialog: 
 

 
 

 
  

OH-ClassPad 
lets you send 
information 
management 
tool to the 
OHP projector 
for 
presentations 
OHP-screen! 

• When selecting a field disabled would lead to an 
automatic change of [Screen copy to] settings of 
the presentation and Communication dialogue 
boxes to the [Outer device]; 

• Files are numbered from P1 to P20. These 
numbers are fixed and can not be changed; 

• When you created a new presentation file can be 
his name; 

• The name of each file is visible and its size in 
pages; 

• The soft keyboard appears automatically when 
you start the application. 
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Once the application is launched from file-list is selected the first row (from 

P1 to P20). The cursor appears on the line chosen by us, which allows to introduce 
eight byte file name. When ready press (EXE). You should make sure that the name 
that has just entered is selected. When you select Print screen, automatically adds the 
selected image in our presentation. Only when disable is selected process is 
terminated. The presentation runs from one of these buttons: 6 7. 
 

As for selection opens a dialog that allows to select the desired presentation. 
When selecting the first button presentation starts and ends only when all the slides be 
listed. When selecting the second button it is controlled by us. 
 
 

           
 
 
 
 
1.3  Geometry application 

 
 

 Geometry application allows to plot and analyze geometric figures. It can be 
plotted triangle and to determine accurately the relationship of the parties in the terms, 
such as 3:4:5, and check the size of the angles at each change.  
 

It can be drawn a circle and then right, which is tangential to a particular point 
of the circle. This application also includes an option to animate shapes, which allows 
you to monitor how they change with each change introduced. 
  
 
 The application is launched when selecting the icon G. Draw menu 
provides plotting of points, polygons, straight, ellipses, circles and other geometric 
shapes. 
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 Draw menu contains submenus. It can be used to add the environment section, 
draw the perpendicular at another set point or other geometric shape, and testing of 
geometric theorems. 
  
 
 
 

               
 
 
 
 When you press the arrow to the right u appears. Measurement box, where 
you can see or change the size selected by us. From the toolbar, choose the shape that 
we want to draw. 
 

The application provides 
an opportunity to draw 
figures and functions.  
 
Once plotted, the figure 
may, if desired, be 
moved or edited. 



 -12-

               
 
  
 
 As already mentioned, Geometry application allows for plotting functions. 
This happens when selecting a Function button on the toolbar in which opens a dialog 
box that lets you choose the type of the function (Polar, Parametric, or f(x)) and a 
window, which has the desired function. 
  
 
 

                 
 
 
 
 When choosing Polar screen appears Soft keyboard, a dialog box appears 
radius. In the example below shows the equation r = θ. 
  
 

Point 
Infinite loop 

Vector 
Arch 

Ellipse 
Parabola 
Polygon 

Segment 
Beam 
Circle 
Ellipse 
Hyperbola 
Function 
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 When choosing Parametric prove two functions, giving limits tmin and tmax. 
After drawing the figure may be included in the Main or eActivity. The equation 
appears as a text graphic that appears below. 
 
  
  It allows to add text while working with Geometry application. This is the 
menu Draw → Text in which opens a dialog box for entering text. It enables the 
introduction of both text and mathematical expressions. 
  
 
 

               
 
 
 
  Easy and fast to make measurements of angles, and correcting them. In the 
example shown below is one of the measured angles in a triangle. For this purpose, 
countries are marked by choosing Draw Attachment angle. 
  
 

Function of 
the 
Geometry 
application 
may be 
included in 
the Main or 
eActivity 
application. 
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  It is interesting to note that both sides of the figure formed not one but four 
corners. To assess which of them need only to use drag / drop and put the cursor 
where you want to measure. 
  
 

             
 
  You can use the Expression command and commands from the submenu 
Measurement to meet a number of calculations using the size of angles, length 
countries face area or other measurement values rendered to the figure and results 
displayed on the working window of the Geometry application. 
 
Example: Here are the segments AB and CD, as point C belongs rights AB. Find the 
sum of the angles ACD and BCD. To visualize the result on the screen. 
  

-   plotted are two lines; 
-   marked and the menu is killed attachment angle, which will automatically lead  
    to image the size of angle ACD; 
-   mark up and drag (move) in the other corner; 
-   mark the two lines again and again chosen attachment angle. Thus displayed  
    simultaneously and the two corners. 
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- On the Draw is choose Expression. In the Measurement window which enters 
the formula EXPR = @1 + @2. Thus, the two elements 1) and 2) will be 
selected and the result will be recorded is 3).  
 

 

           
 
 
 
 
Built in the Geometry application  
 
  Construct submenu of the Draw menu assisted learning of geometric theorems. 
In addition to a menu included bisector, perpendicular, midpoint, section parallel lines 
tangent to the curve, as well as rotation, translation, transformation of shapes and 
reflex points. 
  
  For this purpose, before selecting any operation constructs first it must be 
drawn on the main items that will be designed. Only then from the Draw is selected 
Construct one of the options you want: Perpendicular Bisector, Perpendicular, 
Midpoint, Intersection, Angle bisector, Parallel, Tangent to curve, Reflection, 
Translation, Dilation or General transform.  
 
  In the construction of the section of two straight, the overall point can not be 
moved. The principle of finding a common point between a straight and a circle or 
two circles is similar to the section of two straight. 
 
 

- In Translation (displacement) of the line defined values of a vector led to the 
emergence of a new line, which is consistent with the baseline parallel to and 
in accordance with the set values of the vector. It is also moving online by 
selecting the set vector. For that purpose must be drawn a further vector. 
When you open the dialog box is selected.  
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-   to draw the mirror image of the item, the   
    option Reflection. For this purpose, the line    
    is drawn specimen and another to serve as  
    axis. Then mark the base line and select  
    Reflection from Draw menu.  
 
    This automatically made active Reflection   
    button in the toolbar. Select the axis of  
    symmetry and the new line is displayed on   
    the screen 

-  Rotation line option is used, Rotate.  
   Draw up the line and then marking and  
   choose Rotate.  
 
   You must be a point which will be  
   considered a center of rotation.  
   A dialog box appears indicating the angle  
   of rotation. When you are ready press OK. 
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  General Translation, using matrices or vectors allows, in introducing them to 
change shapes. Outcome of change is a new piece that appears on the screen. By 
Geometry application can be drawn to each other symmetrical shapes, as it turns to 
the abscissa and ordinate are symmetrical.  
 
  When the output figure is drawn are selected and all countries. From Draw → 
Construction → General Transform dialog box opens, divided in two. To occur so that 
the new figure is symmetric about x-axis of the initial figure is introduced in the first 
window [1, 0] [0, -1].  
 
  If you want can be done in parallel move by one unit in X and Y. For this 
purpose, writes [1, 1] in the second window, as shown in the example below. 
 

 
 

                     
 
 
 

  It is easier to understand how General Translation works if used together with 
or eActivity Main application, combined with the Geometry application. This makes it 
possible that the following transformations: 
 
 

-    In the Geometry application can choose a point on the figure obtained after 
transformation and point from the output figure. Dragging them in the Main 
application appears on the screen the words that led to transformation; 
 

-    You can choose a triangle, dragging it to Main, turn of the triangle as a matrix 
with two rows and three pillars, which depicts three coordinates. Is valid and 
reverse operation. 
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Geometry application and animation  
   
  The animation contains one or more points / curves like curves can be a line 
segment, circle, ellipse or function. The animation is built in the choice of point / 
curve and added to the Animation. Can happen in two ways. One is by selecting 
Edit → Animate, and the other is selected from the toolbar View → Animation UI  
 
  Draw is the first point and the curve at which it will move. Then marked from 
the main menu and choose Edit → Animate → Add animation, in which our 
chosen point automatically moves the curve. If after selecting Edit → Animate → 
Go (once) / Go (repeat) / Go (to and fro) appears to be how to move it. When 
choosing Stop animation stops. 
 
 
 

It should be noted that 
this operation is only 
possible if the points 
that are selected are the 
main figure and this 
correspondent.  
 
Nothing will appear in 
the selection of two 
points of the new figure 
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Working with files in the Geometry application 
 
 

 
 

 
If you are required to change a set of us animation is 
elected Edit → Animate → Edit Animation. Appears 
next dialog.  
 
It may prove what is the step of movement. These 
settings indicate steps that point D will be done in 
animation and AB. Sub menu Animations appear all 
points that are animated. In our case, point D. if you 
select Remove to remove the applied point. 't0' and 't1' 
indicate the curve AB. Example, if you change the 
settings of t0 from 0 to 0.5 will result in a change to the 
starting position and animated section will start its 
movement from the middle of the curve AB. 

When choosing a fillet File → Save to open the 
following dialog box. 
 
Select the directory where you want to save, as it 
turns out a name that should be a size 8 bytes. 
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1.4   3D Dimensional Graph application 
 

  This application allows you to draw 3D graphics on the type of z = f (x,y) and 
parametric equations. It starts from the icon 3D graphics D, in which the screen 
opens the 3D graph editor and the 3D graph window. Functions that are mapped in 3D 
graph editor is displayed in the 3D graph window. 
 

 

 
 
 

 
At the bottom status bar is visible. Real indicates that the regime is Real mode (real 
number calculation). The other mode which ClassPad lets you select is working with 
complex numbers Cplx (Complex number calculation). Rad shows that work in 
radians. Other options are Gra and Deg. 

Save the file under a    
     different name 

  Search  
    files 

  Rename  
     files 

The 3D graph editor has 5 separate pages from 
sheet1 - sheet5.  
 
Each page contains up to 20 functions.  
 
This means that you can sort the 100 features in a 
3D graphics.  
 
You can select one of the functions and its image 
will appear in the graph window.  
The figure can be rotated and seen from different 
angles.
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  As said you can enter the type of functions z = f (x,y) or entering parametric 
equations. 
 
 
 z = f(x,y)          parametric equations 
 

                             
 
 
 

 

      
 

 
 
 
 
The example below is a function z = xy, using different settings in the 3D Graph 
View Window. 
 

 
 
 
 

You can use the 3D 
Graph View Window to 
configure the minimum 
and maximum values 
for x-, y-, z-coordinates, 
and s and t variables 
used in the introduction 
of parametric equations. 
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   xmin/ ymin= -3, xmax/ ymax=3           xmin/ ymin= -1, xmax/ ymax= -1     
 
 

                      
 
xgrid/ ygrid= 10                                           Initial default  
 
 
 
 
Using Trace to read 3D graphics 
 
 
  Pressing = the screen as an exchange through which control the way that 
the mouse / cursor does appear as coordinates of each selected point. 
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The calculation of the values of the z-coordinate in input values x and y is done by 
the main menu select Analysis → z-Cal.  
 
Than that opens following dialog: 
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Figure 4.3 
 

 
 
Figure 4.4   
 

 
 
 
Example 1 
The example below shows the closeness of the approximation xa of the following diffe-
rential equation dx/dt=x2/(t+1), x(0)=1, using the Euler method with step h = 0.10 and xb, 
which point was obtained using step h = s = 0.05, and the calculated values of xa(t) and 
xb(t) for t = 0.1, 0.2, 0.3 ,..., 1.0. 
Values obtained are compared with the exact solution x(t): 
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The exact solution to a differential equation is  x=x(t)=1/(1-ln(t+1)). 
The numerical solutions xa and xb and their errors are shown in the table. 
Below you can see the formulas by which it is calculated each row. 
 
 
For xa: 
 

 
 
For xb: visible that xb is used in smaller step (s = 0.05), values are calculated in the last 
column: 
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For the exact solution: 
 

 
 
For the calculation of each line it is taken from the previous value: 
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|x-xa| shows the error which we have worked: 
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Example 2 
The problem has been solved using the Runge-Kutta method. As already mentioned, the 
method is more complex to implement, but is more accurate than the Euler method. 
For example is taken non-linear differential equation 
4y’=x2+y2, y(0)=1. The values for x1, x2 and x3 respectively are 0.8, 1.6, 2.4 (h = r = 0.8). 
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As clearly seen to find any single point is necessary first to find the constants с1, с2, с3 
and с4. Each of them is using the formulas described above. 
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For greater accuracy and precision, the task can be solved by using a small step (not here 
as h = 0.8). 
 
The values for x are in 0.05, reaching a value 2.4: 
 

                     
 
 
Then each of the constants are calculated consistently with other step by step starting 
from 0.05 and lead it step 0.8, as shown below. 
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For easier data entry and formulas outside SpreadSheet application declare a function 
with its variables. Every time you want to enter the equation 4y’=x2+y2 is not enough to 
write out f(x,y). As indicated above table it is shown how the calculated с1, с2, с3 and с4 
with step 0.05 and 0.1 respectively, s and h. It is seen that to find any formula used to 
disclose a function f (x, y). A2 and F2 are x and y. 
  
 

When we work with, these values 
can be set in the Main or eActivity 
and can be used in SpreadSheet 
application. 
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Each subsequent value of the constants is taking value from the previous row. 
  
 

                  
 
  
The values of the points calculated using these constants. 
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The same is done for the remaining steps p, r and m. 
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5. Create programs with ClassPad 
 
ClassPad allows the creation of programs when it is necessary to perform the same 
calculations repeatedly. Use the Program Application. The menu contains a Program 
Editor for entering data and a Program Loader for loading existing programs. 
  
 

   
 
 
In the next field parameters themselves if they occur. And yelling at each program, if 
such a set must not be missed. 
 

     
 
 
Example, establishing a program rests on the basis of the Runge-Kutta method. Made 
program, which introduces the steps and points х1, …, хn, which the program calculates 
the numerical solutions of differential equation 4y’=x2+y2. 
  

The Program Loader opens 
automatically when loading the 
application. 
The Program Editor is used to 
introduce new programs or to 
edit existing ones.  
With N turns out to be the type 
of file that you create.  
It can be a text (T), 
programming (N) or defined 
function file (F) 
 



 -135-

 

 
 
 
Code: 
 
DelVar x,y 
seq(0,y,0,n-1,1)⇒Listy 
seq(0,c,0,n-1,1)⇒ListC1 
seq(0,c,0,n-1,1)⇒ListC2 
seq(0,c,0,n-1,1)⇒ListC3 
seq(0,c,0,n-1,1)⇒ListC4 
approx(seq(x,x,0,(n-1)*h,h))⇒Listx 
1⇒y 
1⇒Listy[1] 
For 2⇒k To n Step 1 
Listx[k-1]⇒x 
approx(h*f(x,y))⇒ListC1[k]:ListC1[k]⇒C1 
approx(h*f(x+h/2,y+C1/2))⇒ListC2[k]:ListC2[k]⇒C2 
approx(h*f(x+h/2,y+C2/2))⇒ListC3[k]:ListC3[k]⇒C3 
approx(h*f(x+h,y+C3))⇒ListC4[k] 
approx(y+(ListC1[k]+2*ListC2[k]+2*ListC3[k]+ListC4[k])/6)⇒y 
approx(y)⇒Listy[k] 
Next 
DispListEditor 
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By creating programs quickly and easily change values to obtain the satisfying results. 
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